package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:https?:\/\/)(?:www\.)?([^\/\s]+)$|^(?:https?:\/\/)(?:www\.)?([^\/\s]+)(?:.*)$`)
var str = `https://domain.com
https://subdomain.domain.com
https://www.sub.sub.subdomain.domain.com
http://sub.masterdomain.com.au
https://four.submains.new.domain.luxury.co.uk
https://www.globo.us/games/tap-zap-boom/
https://www.test.com/games/socce/index.html
https://google.com.br/services/index.php`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}