use strict;
my $str = 'https://domain.com
https://subdomain.domain.com
https://www.sub.sub.subdomain.domain.com
http://sub.masterdomain.com.au
https://four.submains.new.domain.luxury.co.uk
https://www.globo.us/games/tap-zap-boom/
https://www.test.com/games/socce/index.html
https://google.com.br/services/index.php';
my $regex = qr/^(?:https?:\/\/)(?:www\.)?([^\/\s]+)$|^(?:https?:\/\/)(?:www\.)?([^\/\s]+)(?:.*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}