re = /^(?:https?:\/\/)(?:www\.)?([^\/\s]+)$|^(?:https?:\/\/)(?:www\.)?([^\/\s]+)(?:.*)$/m
str = 'https://domain.com
https://subdomain.domain.com
https://www.sub.sub.subdomain.domain.com
http://sub.masterdomain.com.au
https://four.submains.new.domain.luxury.co.uk
https://www.globo.us/games/tap-zap-boom/
https://www.test.com/games/socce/index.html
https://google.com.br/services/index.php'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end