using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\|\|\w{9}\|HEX\|color.*?|([\|])?\|\w{9}\|HEX\|color)|(\|)";
string input = @"Sample|text||new line|||cFFFFFF00|HEX|colorText in color|this will be inner new line|cFFC6C6C6|HEX|colorReset color. The following goes into the next line too:||hello world";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}