re = /(?:\|\|\w{9}\|HEX\|color.*?|([\|])?\|\w{9}\|HEX\|color)|(\|)/m
str = 'Sample|text||new line|||cFFFFFF00|HEX|colorText in color|this will be inner new line|cFFC6C6C6|HEX|colorReset color. The following goes into the next line too:||hello world'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end