import re
regex = re.compile(r"(?:\|\|\w{9}\|HEX\|color.*?|([\|])?\|\w{9}\|HEX\|color)|(\|)", flags=re.MULTILINE)
test_str = "Sample|text||new line|||cFFFFFF00|HEX|colorText in color|this will be inner new line|cFFC6C6C6|HEX|colorReset color. The following goes into the next line too:||hello world"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")