const regex = new RegExp('(?:\\|\\|\\w{9}\\|HEX\\|color.*?|([\\|])?\\|\\w{9}\\|HEX\\|color)|(\\|)', 'gm')
const str = `Sample|text||new line|||cFFFFFF00|HEX|colorText in color|this will be inner new line|cFFC6C6C6|HEX|colorReset color. The following goes into the next line too:||hello world`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}