using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?<name>[A-Za-z0-9]+)\s*=\s*(?:\""(?<people>[A-Za-z0-9]+)\"",?\s*)+;";
string input = @"People = ""Alice"", ""Bob"", ""Charlie"", ""David"", ""Erica"", ""Fred"";";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}