package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?<name>[A-Za-z0-9]+)\s*=\s*(?:\"(?<people>[A-Za-z0-9]+)\",?\s*)+;`)
var str = `People = "Alice", "Bob", "Charlie", "David", "Erica", "Fred";`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}