re = /\b(?<name>[A-Za-z0-9]+)\s*=\s*(?:\"(?<people>[A-Za-z0-9]+)\",?\s*)+;/m
str = 'People = "Alice", "Bob", "Charlie", "David", "Erica", "Fred";'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end