$re = '/\b(?<name>[A-Za-z0-9]+)\s*=\s*(?:\"(?<people>[A-Za-z0-9]+)\",?\s*)+;/m';
$str = 'People = "Alice", "Bob", "Charlie", "David", "Erica", "Fred";';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);