const regex = new RegExp('(\\d{1,3}.\\d{1,3}.\\d{1,3}.\\d{1,3})\\ \\<\\d+\\>\\ -\\ .+\\ \\[([0-9]{2}\\/(?:Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)\\/[0-9]{4}:[0-9]{2}:[0-9]{2}:[0-9]{2})\\ [+|-]\\d\\d\\d\\d\\]\\ \\"(?:(PATCH|GET|POST|PUT|HEAD|DELETE|OPTIONS|CONNECT|TRACE))\\ ([^\\ ?]+).+\\"\\ 200\\ \\d+\\ (\\d+.\\d+)', 'gm')
const str = `127.0.0.1 <3772> - 5a856643-2ac9-402f-83bf-fcb088513e64 [18/Dec/2018:10:42:42 -0300] "POST /engine/task_result HTTP/1.1" 200 4 0.663223`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}