import re
regex = re.compile(r"(\d{1,3}.\d{1,3}.\d{1,3}.\d{1,3})\ \<\d+\>\ -\ .+\ \[([0-9]{2}\/(?:Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)\/[0-9]{4}:[0-9]{2}:[0-9]{2}:[0-9]{2})\ [+|-]\d\d\d\d\]\ \"(?:(PATCH|GET|POST|PUT|HEAD|DELETE|OPTIONS|CONNECT|TRACE))\ ([^\ ?]+).+\"\ 200\ \d+\ (\d+.\d+)", flags=re.MULTILINE)
test_str = "127.0.0.1 <3772> - 5a856643-2ac9-402f-83bf-fcb088513e64 [18/Dec/2018:10:42:42 -0300] \"POST /engine/task_result HTTP/1.1\" 200 4 0.663223"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")