// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(\d{1,3}.\d{1,3}.\d{1,3}.\d{1,3})\ \<\d+\>\ -\ .+\ \[([0-9]{2}\/(?:Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)\/[0-9]{4}:[0-9]{2}:[0-9]{2}:[0-9]{2})\ [+|-]\d\d\d\d\]\ \"(?:(PATCH|GET|POST|PUT|HEAD|DELETE|OPTIONS|CONNECT|TRACE))\ ([^\ ?]+).+\"\ 200\ \d+\ (\d+.\d+)"#).unwrap();
let string = "127.0.0.1 <3772> - 5a856643-2ac9-402f-83bf-fcb088513e64 [18/Dec/2018:10:42:42 -0300] \"POST /engine/task_result HTTP/1.1\" 200 4 0.663223";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}