package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*\S\R)(\d)(\R0)$`)
var str = `ABC
5
0
gdfgdfg
-----------
GHN
3
0
ffffffff
fffff
ffff
trte
-------------
H
1
0
----------------`
var substitution = "$1$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}