import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*\\S\\R)(\\d)(\\R0)$";
final String string = "ABC\n"
+ "5\n"
+ "0\n"
+ "gdfgdfg\n"
+ "-----------\n"
+ "GHN\n"
+ "3\n"
+ "0\n"
+ "ffffffff\n"
+ "fffff\n"
+ "ffff\n"
+ "trte\n"
+ "-------------\n"
+ "H\n"
+ "1\n"
+ "0\n"
+ "----------------";
final String subst = "$1$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}