re = /^(.*\S\R)(\d)(\R0)$/m
str = 'ABC
5
0
gdfgdfg
-----------
GHN
3
0
ffffffff
fffff
ffff
trte
-------------
H
1
0
----------------'
subst = '$1$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result