using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@media[^{]+([\s\S]+})\s*";
string input = @" @media (max-width: 600px) { color: red; }";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}