$re = '/@media[^{]+([\s\S]+})\s*/';
$str = ' @media (max-width: 600px) { color: red; }';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);