package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`@media[^{]+([\s\S]+})\s*`)
var str = ` @media (max-width: 600px) { color: red; }`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}