re = /@media[^{]+([\s\S]+})\s*/
str = ' @media (max-width: 600px) { color: red; }'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end