using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*(?:M(?:iss|rs?|s)|Dr|Rev|Er)\b[\s.]*";
string input = @"Mr. Aftab
Dr . Amir
mrs . kapoor
Er. Elon Musk
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}