re = /^\s*(?:M(?:iss|rs?|s)|Dr|Rev|Er)\b[\s.]*/im
str = 'Mr. Aftab
Dr . Amir
mrs . kapoor
Er. Elon Musk
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end