import re
regex = re.compile(r"^\s*(?:M(?:iss|rs?|s)|Dr|Rev|Er)\b[\s.]*", flags=re.IGNORECASE | re.DOTALL | re.MULTILINE)
test_str = ("Mr. Aftab\n"
"Dr . Amir\n"
"mrs . kapoor\n"
"Er. Elon Musk\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")