package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d\-\d$|^[a-zA-Z]\-[a-zA-Z]$`)
var str = `2-3
2-6
a-e
f-y
^-j
A-Z
A-E`
var substitution = "£"
fmt.Println(re.ReplaceAllString(str, substitution))
}