import re
regex = re.compile(r"^\d\-\d$|^[a-zA-Z]\-[a-zA-Z]$", flags=re.MULTILINE)
test_str = ("2-3\n"
"2-6\n"
"a-e\n"
"f-y\n"
"^-j\n"
"A-Z\n"
"A-E")
subst = "£"
result = regex.sub(subst, test_str)
if result:
print(result)