// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d\-\d$|^[a-zA-Z]\-[a-zA-Z]$").unwrap();
let string = "2-3
2-6
a-e
f-y
^-j
A-Z
A-E";
let substitution = "£";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}