#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\+?0*(?:91-)?\K(?:91)?[6-9][0-9]{9}$"
Local $sString = "+918877665544" & @CRLF & _
"0918877665544" & @CRLF & _
"0000918877665544" & @CRLF & _
"" & @CRLF & _
"+91-8877665544" & @CRLF & _
"91-8877665544" & @CRLF & _
"00008877665544" & @CRLF & _
"" & @CRLF & _
"+91-88776655440" & @CRLF & _
"91-88-77665544" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"+818877665544" & @CRLF & _
"0918877665544" & @CRLF & _
"0000918877665544" & @CRLF & _
"" & @CRLF & _
"+91-8877665544" & @CRLF & _
"92-8877665544" & @CRLF & _
"00002877665544"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")