import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\+?0*(?:91-)?\\K(?:91)?[6-9][0-9]{9}$";
final String string = "+918877665544\n"
+ "0918877665544\n"
+ "0000918877665544\n\n"
+ "+91-8877665544\n"
+ "91-8877665544\n"
+ "00008877665544\n\n"
+ "+91-88776655440\n"
+ "91-88-77665544\n\n\n"
+ "+818877665544\n"
+ "0918877665544\n"
+ "0000918877665544\n\n"
+ "+91-8877665544\n"
+ "92-8877665544\n"
+ "00002877665544";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}