use strict;
my $str = '+918877665544
0918877665544
0000918877665544
+91-8877665544
91-8877665544
00008877665544
+91-88776655440
91-88-77665544
+818877665544
0918877665544
0000918877665544
+91-8877665544
92-8877665544
00002877665544';
my $regex = qr/^\+?0*(?:91-)?\K(?:91)?[6-9][0-9]{9}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}