const regex = /^\+?0*(?:91-)?\K(?:91)?[6-9][0-9]{9}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\+?0*(?:91-)?\\K(?:91)?[6-9][0-9]{9}$', 'gm')
const str = `+918877665544
0918877665544
0000918877665544
+91-8877665544
91-8877665544
00008877665544
+91-88776655440
91-88-77665544
+818877665544
0918877665544
0000918877665544
+91-8877665544
92-8877665544
00002877665544`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}