# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<\?xml version="1\.0" encoding="UTF-8"\?>\s*<\s*([^\s]*)(?:.|\s)*<\\/\s*\1\s*>//gm;t' <<< "--------------------------3cbec9ce8f05
Content-Disposition: form-data; name=\"owServerData\"; filename=\"details.xml\"
Content-Type: text/plain
<?xml version=\"1.0\" encoding=\"UTF-8\"?>
<Devices-Detail-Response xmlns=\"http://www.example.com\"
<device>a</device>
<info>abc</info>
<test1><u>123</u><v>456</v><z/></test1>
</Devices-Detail-Response>
------------------------------3cbec9ce8f05--"