import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\?xml version=\"1\\.0\" encoding=\"UTF-8\"\\?>\\s*<\\s*([^\\s]*)(?:.|\\s)*<\\/\\s*\\1\\s*>";
final String string = "--------------------------3cbec9ce8f05\n"
+ "Content-Disposition: form-data; name=\"owServerData\"; filename=\"details.xml\"\n"
+ "Content-Type: text/plain\n\n"
+ "<?xml version=\"1.0\" encoding=\"UTF-8\"?>\n"
+ "<Devices-Detail-Response xmlns=\"http://www.example.com\" \n"
+ " <device>a</device>\n"
+ " <info>abc</info>\n"
+ " <test1><u>123</u><v>456</v><z/></test1>\n"
+ "</Devices-Detail-Response>\n"
+ "------------------------------3cbec9ce8f05--";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}