# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<\?xml version=\"1\.0\" encoding=\"UTF-8\"\?>\s*<\s*([^\s]*)(?:.|\s)*<\/\s*\1\s*>"
test_str = ("--------------------------3cbec9ce8f05\n"
"Content-Disposition: form-data; name=\"owServerData\"; filename=\"details.xml\"\n"
"Content-Type: text/plain\n\n"
"<?xml version=\"1.0\" encoding=\"UTF-8\"?>\n"
"<Devices-Detail-Response xmlns=\"http://www.example.com\" \n"
" <device>a</device>\n"
" <info>abc</info>\n"
" <test1><u>123</u><v>456</v><z/></test1>\n"
"</Devices-Detail-Response>\n"
"------------------------------3cbec9ce8f05--")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.