using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\?xml version=""1\.0"" encoding=""UTF-8""\?>\s*<\s*([^\s]*)(?:.|\s)*<\/\s*\1\s*>";
string substitution = @"";
string input = @"--------------------------3cbec9ce8f05
Content-Disposition: form-data; name=""owServerData""; filename=""details.xml""
Content-Type: text/plain
<?xml version=""1.0"" encoding=""UTF-8""?>
<Devices-Detail-Response xmlns=""http://www.example.com""
<device>a</device>
<info>abc</info>
<test1><u>123</u><v>456</v><z/></test1>
</Devices-Detail-Response>
------------------------------3cbec9ce8f05--";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}