using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d+)L(?:-(\d+(?:\.\d+)?))?([_-].*)?";
string input = @"15L-0.3
16L-0.4_redo
15L-0
16L-redo";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}