re = /^(\d+)L(?:-(\d+(?:\.\d+)?))?([_-].*)?/m
str = '15L-0.3
16L-0.4_redo
15L-0
16L-redo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end