$re = '/^(\d+)L(?:-(\d+(?:\.\d+)?))?([_-].*)?/m';
$str = '15L-0.3
16L-0.4_redo
15L-0
16L-redo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);