const regex = new RegExp('^(\\d+)L(?:-(\\d+(?:\\.\\d+)?))?([_-].*)?', 'gm')
const str = `15L-0.3
16L-0.4_redo
15L-0
16L-redo`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}