#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "weapon(?:(?:_[^\W_]+)+(?=_[^\W_]{2}_)|(?:(?!_[^\W_]{2}_)_[^\W_]+)+)"
Local $sString = "econ/default_generated/weapon_knife_flip_so_night_medium" & @CRLF & _
"econ/default_generated/weapon_bayonet_hy_ocean_knife_medium" & @CRLF & _
"econ/default_generated/weapon_knife_gut_aq_blued_heavy" & @CRLF & _
"econ/default_generated/weapon_knife_karambit_hy_webs_medium" & @CRLF & _
"econ/default_generated/weapon_knife_m9_bayonet_so_night_lightasd" & @CRLF & _
"econ/default_generated/weapon_knife_tactical_hy_ddpat_light" & @CRLF & _
"econ/default_generated/weapon_knife_falchion_aa_fade_heavy" & @CRLF & _
"econ/default_generated/weapon_knife_survival_bowie_am_doppler_phase3_heavy" & @CRLF & _
"econ/default_generated/weapon_knife_butterfly_hy_ddpat_medium" & @CRLF & _
"econ/default_generated/weapon_knife_push_hy_ddpat_light"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")