# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"weapon(?:(?:_[^\W_]+)+(?=_[^\W_]{2}_)|(?:(?!_[^\W_]{2}_)_[^\W_]+)+)"
test_str = ("econ/default_generated/weapon_knife_flip_so_night_medium\n"
"econ/default_generated/weapon_bayonet_hy_ocean_knife_medium\n"
"econ/default_generated/weapon_knife_gut_aq_blued_heavy\n"
"econ/default_generated/weapon_knife_karambit_hy_webs_medium\n"
"econ/default_generated/weapon_knife_m9_bayonet_so_night_lightasd\n"
"econ/default_generated/weapon_knife_tactical_hy_ddpat_light\n"
"econ/default_generated/weapon_knife_falchion_aa_fade_heavy\n"
"econ/default_generated/weapon_knife_survival_bowie_am_doppler_phase3_heavy\n"
"econ/default_generated/weapon_knife_butterfly_hy_ddpat_medium\n"
"econ/default_generated/weapon_knife_push_hy_ddpat_light")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.