import Foundation
let pattern = #"weapon(?:(?:_[^\W_]+)+(?=_[^\W_]{2}_)|(?:(?!_[^\W_]{2}_)_[^\W_]+)+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
econ/default_generated/weapon_knife_flip_so_night_medium
econ/default_generated/weapon_bayonet_hy_ocean_knife_medium
econ/default_generated/weapon_knife_gut_aq_blued_heavy
econ/default_generated/weapon_knife_karambit_hy_webs_medium
econ/default_generated/weapon_knife_m9_bayonet_so_night_lightasd
econ/default_generated/weapon_knife_tactical_hy_ddpat_light
econ/default_generated/weapon_knife_falchion_aa_fade_heavy
econ/default_generated/weapon_knife_survival_bowie_am_doppler_phase3_heavy
econ/default_generated/weapon_knife_butterfly_hy_ddpat_medium
econ/default_generated/weapon_knife_push_hy_ddpat_light
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)