const regex = /weapon(?:(?:_[^\W_]+)+(?=_[^\W_]{2}_)|(?:(?!_[^\W_]{2}_)_[^\W_]+)+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('weapon(?:(?:_[^\\W_]+)+(?=_[^\\W_]{2}_)|(?:(?!_[^\\W_]{2}_)_[^\\W_]+)+)', 'g')
const str = `econ/default_generated/weapon_knife_flip_so_night_medium
econ/default_generated/weapon_bayonet_hy_ocean_knife_medium
econ/default_generated/weapon_knife_gut_aq_blued_heavy
econ/default_generated/weapon_knife_karambit_hy_webs_medium
econ/default_generated/weapon_knife_m9_bayonet_so_night_lightasd
econ/default_generated/weapon_knife_tactical_hy_ddpat_light
econ/default_generated/weapon_knife_falchion_aa_fade_heavy
econ/default_generated/weapon_knife_survival_bowie_am_doppler_phase3_heavy
econ/default_generated/weapon_knife_butterfly_hy_ddpat_medium
econ/default_generated/weapon_knife_push_hy_ddpat_light`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}