package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z0-9][A-Za-z0-9._-]*@[A-Za-z]+\.(?:com|net|org|co)(?:\.uk)?$`)
var str = `.ilikestack@gmail.com
ilikestack@gmail.com_
ilikestack@gmail.com
ilike.stack@gmail.co.uk
i@1.co
i@1.c
i@1.c.a
i@1.1
i@abcabca.abcabcaabcabcaabcabca.abcabca`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}