use strict;
my $str = '.ilikestack@gmail.com
ilikestack@gmail.com_
ilikestack@gmail.com
ilike.stack@gmail.co.uk
i@1.co
i@1.c
i@1.c.a
i@1.1
i@abcabca.abcabcaabcabcaabcabca.abcabca';
my $regex = qr/^[A-Za-z0-9][A-Za-z0-9._-]*@[A-Za-z]+\.(?:com|net|org|co)(?:\.uk)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}