import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Za-z0-9][A-Za-z0-9._-]*@[A-Za-z]+\\.(?:com|net|org|co)(?:\\.uk)?$";
final String string = ".ilikestack@gmail.com\n"
+ "ilikestack@gmail.com_\n"
+ "ilikestack@gmail.com\n"
+ "ilike.stack@gmail.co.uk\n"
+ "i@1.co\n"
+ "i@1.c\n"
+ "i@1.c.a\n"
+ "i@1.1\n"
+ "i@abcabca.abcabcaabcabcaabcabca.abcabca";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}