using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)<\/?\w+[^>]*>(*SKIP)(?!)|\b(\p{Latin})\s";
string substitution = @"\1 ";
string input = @"Dziedziczenie dlugów spadkowych jest wciąż bardzo żywym tematem, pomimo korzystnej dla spadkobierców zmiany przepisów w 2015 roku, o ē której szerzej pisałem na blogu <a href=""http://www.prawnik-katowice.pl/blog-prawniczy/dziedziczenie-dlugow-od-18-pazdziernika-2015-roku/"">tutaj</a>.
";
RegexOptions options = RegexOptions.CultureInvariant | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}