#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ">(.*)<|data-event-title="([^*]*.).*""
Local $sString = "data-event-title="Yuichi Sugita* vs Adrian Mannarino">" & @CRLF & _
" <span class="odds-container">" & @CRLF & _
" <b class="odds">1/12</b>" & @CRLF & _
" </a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")