package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`>(.*)<|data-event-title="([^*]*.).*"`)
var str = `data-event-title="Yuichi Sugita* vs Adrian Mannarino">
<span class="odds-container">
<b class="odds">1/12</b>
</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}