import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ">(.*)<|data-event-title=\"([^*]*.).*\"";
final String string = "data-event-title=\"Yuichi Sugita* vs Adrian Mannarino\">\n"
+ " <span class=\"odds-container\">\n"
+ " <b class=\"odds\">1/12</b>\n"
+ " </a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}